MSYS perl not executing properly

How can I fix my installation of msys?

Setup:

  • MinGW64/MSYS
  • Windows 10

I noticed this when trying to run git add --patch

pacman -S perl successfully completes installation of the perl package.

Problem

When I run any perl command it just returns a blank line.

e.g.

$ perl --version

$ 
$ git add --patch

$ 

The mingw64/mingw-w64-x86_64-perl works correctly however when only this version is installed the git add --patch command returns maybe git-add--interactive is broken

Troubleshooting

whereis perl /mingw64/bin/perl.exe and if the msys version is installed /usr/bin/perl

Both MinGW and msys versions of perl tried. Only the MinGW version works for perl but then git cannot find it.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s